
APPLICATION NOTE
THIS INFORMATION PROVIDED BY AUTOMATIONDIRECT.COM TECHNICAL 
SUPPORT IS PROVIDED "AS IS" WITHOUT A GUARANTEE OF ANY KIND.

These documents are provided by our technical support department to assist others. We
do not guarantee that the data is suitable for your particular application, nor do we
assume any responsibility for them in your application.

Purpose
This application note is intended to provide a basic project configuration for controlling an LS Electric iX7NH or PHOX EtherCAT servo drive using a LS Electric 
XMC programmable motion controller.

Subject
XMC XG5000 EtherCAT Project Creation

Date Issued
2-17-2025



XMC01 – Getting Connected out of the box USB and Ethernet
• XMCs are programmed in XG5000.
• After mounting and powering it up, a user can connect to it through XG5000 for programming.
• XG5000 can connect to the XMC with a USB series Mini-B cable or an Ethernet cable.
• A USB series mini-B cable will connect to the port under the RUN/STOP Mode Switch and SD CMD button. 
(Shown Below)
• An ethernet cable will connect to the Ethernet port on the front.
• The EtherCAT port can not be used for programming.

Two methods 
for connecting 
with XG5000

XG5000 XMC Connection Options

Ethernet



Section 1 – USB Connection to XMC
Step 1: Download and Install XG5000 software.  

Step 2: Connect Computer with USB series Mini-B cable to the XMC.

USB mini-B Cable



Step 3: Open XG5000. Select Project Menu→ New Project.     
           Alternate method is to Select Project Menu → Open From PLC… (Skip to Step 6).

Step 4: Fill in the information for a New Project.

Add Project Name

Choose XMC

Choose CPU type XMC-E16A or XMC-E08A

Add Program Name
Choose Program Language



Step 5: Select Online Menu → Connection Settings…

Step 6: Select USB as type.  Press the Connect button when ready to connect.



Step 7: XG5000 should display connection status at the bottom part of the software. Example Below.

If Using Open From PLC…, These screens will 
appear before the project is opened and 
showing connection status.



Section 2 – Ethernet Connection to the XMC
Step 1: Download and Install XG5000 software.  

Step 2: Connect Computer with Ethernet cable to the XMC.

Ethernet Cable

Note: Default IP address of CPU is 192.168.250.110
Default Sub-net: 255.255.255.0



Step 5: Fill in the information for a New Project.

Step 3: Change Computer network settings to be on the same sub-net range as the XMC.
 Note: If you can not change the IP address setup on your PC, try the USB connection.

Example: Set PC IP Address to 192.168.250.101
 Set PC Sub-net to 255.255.255.0

Step 4: Open XG5000. Select Project Menu→ New Project.     
           Alternate method is to Select Project Menu → Open From PLC… (Skip to Step 7).

Add Project Name

Choose XMC

Choose CPU type XMC-E16A or XMC-E08A

Add Program Name
Choose Program Language



Step 6: Select Online Menu → Connection Settings…

Step 7: Select Ethernet as type.  Press the Settings... Button to enter IP address information.



Step 8: Enter the default IP address of 192.168.250.110 in the IP address field. Press OK when done.

Step 9: Press Connect button to connect to XMC CPU.



Step 10: XG5000 should display connection status at the bottom part of the software. Example Below.

If Using Open From PLC…, These screens will 
appear before the project is opened and 
showing connection status.



Section 2.1 – Using Network Browsing to find IP Address of XMC CPU
Network Browsing can be used to find the IP address of an XMC.  Connection settings can be found in Online 
Menu -> Connection Settings.

Select Network Browsing to 
open a new window.

Expand Ethernet Section to 
see the IP address of any 
XMC that is found.



Section 3 – Online Status Bar
XG5000 software displays various information in the Online Status Bar.

This is the name 
in the project.

Current mode of 
the XMC.

Current Connection Settings 
to the XMC.

Color will change for RUN mode versus STOP mode.



XMC02 – Adding ESI Files to XG5000 for Non-LS Devices
• The information for an EtherCAT slave is defined in the EtherCAT Slave Information (ESI) file.
• This file must be supplied by the manufacturer of the device.
• XG5000 can read the ESI file to configure communication settings for the XMC to connect with the EtherCAT slave.
• The EtherCAT slave must support the version of the ESI file being used. 
Section 1  – Adding ESI file to XG5000
Step 1: Close all Instances of XG5000 and download the ESI file for your device.
Step 2: Open a Windows Explorer and navigate to C:\XG5000\EtherCATXML.

Step 3: Copy your device’s ESI file to C:\XG5000\EtherCATXML. This example shows copying an ESI file for a Kollmorgen AKD2G.



Step 4: Open your XMC project in XG5000.

Step 5: Select View Menu -> ESI Library Window

Step 6: The EtherCAT slave should appear in the ESI Library window. This device can now be added to the XMC project.



XMC03 – Adding Slaves to an XMC Project
• There are two ways to add slaves to an XMC project.
• They can be added manually or by using Auto-Connect.
• Manually adding slaves doesn’t require slaves to be powered on or connected to the EtherCAT master.
• ESI files for non-LS Electric devices need to be added prior to manually adding that device. 
• This example shows adding some LS Electric iX7NH Servo Drives to your project.

Table of Contents
Section 1  – Manually Adding a Slave to Your Project
Section 2  – Automatically Adding Slaves to Your Project using Auto-Connect
Section 3 – Changing EtherCAT Cycle time



Section 1  – Manually Adding a Slave to Your Project
Step 1: In the Project Window, Right click on Slave under EtherCAT Parameter Section.  Select Add item - > Add Slave…

Step 2: Press the ‘…’ button next to the Slave Name property.



Step 3: Select Your device from the pop-up screen.   Press OK when done.
Note: Vendor can be changed to find non-LS Electric devices.  

Select Vendor if using a non-LS Electric device.



Step 4: Press OK on the Slave information screen to add the slave to the project.

Slave gets added to the Project Window. If the slave is a 
servo drive, stepper drive, or a compatible AC Drive, an Axis 
will automatically be assigned to the slave.

Step 5: Repeat Steps 1 thru 4 for any additional slave devices.



Section 2  – Automatically Adding Slaves to Your Project using Auto-Connect

Step 1: Connect to the XMC with your XG5000 project. Put the XMC into STOP Mode.

Step 2: Select Online Menu -> EtherCAT Slave -> Auto Connect



Step 3: Select the SDO parameter read included option to read the SDO object from the devices.
              Select ‘Slave station number and axis number match’ if you want the Axis numbers for the slave servo devices to match    

the drive node number (station number).

XMC-E08A: Slave Node number (station number) must be between 1-8.
XMC-16A: Slave Node number (station number) must be between 1-16.

Step 4:  XG5000 will show the read status.  Press OK on the status screen when reading is done.



Step 5: Press OK to set axis number to slave drive node number if that option was selected.  Skip if that option was not selected.

Step 6: Press OK on Writing Complete screen.

Slaves are added to the project. Axes are 
automatically assigned if the slave is a servo 
drive, stepper drive, or compatible AC drive.

Step 7: This method will automatically connect the EtherCAT network.  Go to Online Menu -> EtherCAT Slave -> Disconnect to 
disconnect the EtherCAT network.  This will allow you to write the project to the XMC when you are ready for that.



Section 3  – Changing EtherCAT Cycle Time

Step 1: Double Click Basic Parameter in the Project Window.

Step 2: Select the Main Task time for the application.  .5ms/1ms/2ms/4ms are available.



XMC04 – Configuring Axis Parameters
• After adding motion based EtherCAT slaves, the axes associated with those slaves must be configured.
• These parameters should be configured for your specific application. 
• XMC User Manual 5.1.3 contains more details about configuring axis parameters.  Search for ‘(5) Axis parameter’ for quick access 
Section 1  – Opening Axis Parameters.

In the Project Window, Double Click on any Axis in the Axis Parameter Section.  This will open the Axis parameters for all assigned 
axes.



Section 2 – Basic Settings

Axis Number for parameters in the column.
Unit can be set to pulse, mm, inch, or degree.
Set the number of motor pulses for 1 revolution.
If unit is mm, inch or degree, set the amount of distance traveled per 1 revolution of the motor.

Set to Emergency Stop deceleration rate.

Set speed command to unit/sec, unit/min, or rpm.
Set max speed of the Axis.

Choose if Encoder on the motor is incremental or absolute.

Gear ratio values are available if using unit of mm, inch, or degree.

Choose the stopping method for a command that reverses the direction of motion.
NO: Position Control Range will be a 32-bit integer value.
Use: Position Control Range will be a 48-bit integer value.

CSP: Cyclic Synchronous Position Control mode (This is default and should work for most applications)
CSV: Cyclic Synchronous Velocity Control Mode



Section 3 – Extended Settings
Set Software upper position limit.
Set Software lower position limit.
Ring mode position value.
Enable ring mode position on the axis.
Set the range for the in position signal to be on. *Note

Set the behavior for a position deviation error.  Warning or Servo alarm are the options.
Set the current position compensation amount. *Note
Set Speed filter time constant. *Note

0: Ignores software position limits in speed control.  1: Software position limits are enforced in speed control.

Set Backlash compensation amount if applicable to your system. *Note

Set Jogging Parameters

Set the range for tracking position deviation error *Note

*Note: These parameters can be default for many applications.



Section 4 – Using Engineering Units for an Axis Position
• XG5000 allows an axis to be configured to use engineering units such as millimeters, inches and degrees.
• The Axis parameter configuration is very similar between the three different unit types.
• XG5000 function blocks use the engineering units as inputs with the value range of LREAL.
• LREAL value range: 2.2250738585072e-308 ~ 1.79769313486232e+308

Example Using millimeter Units
• This example will cover setting up an axis to move an Igus Drylin series ZLW1040S-2 linear actuator.
• The servo drive will be an iX7NH drive and the motor connected to a 5:1 LS Electric gear box.
• The ZLW1040S-2 has a 70 mm pitch which means every revolution of the input shaft move the actuator mounting plate 70 

mm. 

Set to the unit for your application.  This example will use mm
Set to the number of motor pulses per one revolution.  This is the typical value for iX7 and APMC motors.

For our example this will be the pitch of the linear actuator.

Set the Speed limit of the system.  This should be configured to prevent damage to the system.

5:1 gear box will mean the motor needs to move 5 revolutions to move the gear box shaft 1 revolution.



Actuator has a 200 mm travel limit.  

Configure JOG parameters to be valid for your system.

Since upper limit is set to 200 mm, we set lower limit to 0 mm.



Section 1 – XEL-BSSCT Layout 

USB mini-B port

EtherCAT In port

EtherCAT Node 
Number Switches

• The XEL-BSSCT is an EtherCAT bus coupler that uses XGB I/O modules.
• An XG5000 program is used to configure the XEL-BSSCT and which I/O modules are connected to it.
• XG5000 automatically contains the ESI file for the XEL-BSSCT.
• For other software systems the ESI file may be downloaded here <link to ESI file>

EtherCAT Out port
24 VDC power input

Status LEDs

XMC05 – XMC EtherCAT Remote I/O with XEL-BSSCT
• The XMC support I/O expansion with EtherCAT bus couplers.
• Automation Direct offers the XEL-BSSCT as an EtherCAT bus coupler.
• This topic will cover adding remote I/O to the XMC using the XEL-BSSCT.



Section 1.1 – XEL-BSSCT Status LEDs
Name Color Status Normal/Error Operationbystatus

PWR Red
Off - Power Off
On - Power On

RUN Green

Off - INITstatus
Blinking - PRE-OPstatus

Single Flash - SAFE-OP status
Flickering - Initialization or BOOTSTRAPstatus

On - OPstatus

MS Red/Green

Green
On - RUNmode

Off -
Error has caused STOP mode or operation is not available.

Red

On Error Unrecoverable error has occurred
1s

Flickering Warning
Recoverable error has occurred

500ms
Flickering Light error

Error that has no effect on operation has occurred

100ms
Flickering Criticalerror

Critical error that is halting operation has occurred

ERR Red

Off - Noerror

Blinking Error
General settingerror such as registeror object setting,
or invalidH/Wsetting

Single Flash Error
The EtherCATstate cannot be changed to OP due to
a localerror.

Double Flash Error Occurrenceof sync manager watchdog timeout
Flickering Error Booting error

On Error Hardware failure has occurred.

 L/A 
IN Green

Off -
No connection to the Master.

On -
Connection to the Master has been established but there i s  
n o communication.

Flickering -
Connection to the Master has been established and there is 
communication.

L/A 
OUT Green

Off -
No connection to the Master.

On -
Connection to the Master has been established but there i s  
n o communication.

Flickering -
Connection to the Master has been established and there is 
communication.



Section 2  – Performing Auto-Connect to Add the Bus Coupler to your Project

Step 1: Connect to the XMC with an XG5000 project.
Step 2: Select Online Menu -> EtherCAT Slave -> Auto Connect

• Set a unique node number to the XEL-BSSCT with the rotary switches.
• Connect the EtherCAT network from the XMC port to the IN port of the XEL-BSSCT.



Step 3: Select the SDO parameter read included option to read the SDO object from the devices.

Step 4:  XG5000 will show the read status.  Press OK on the status screen when reading is done.



Step 5: Press OK to set axis number to slave drive node number if that option was selected.  Skip if that option was not selected.

Step 6: Press OK on Writing Complete screen.

XEL-BSSCT will be added to the 
project.

Step 7: Double Click on the XEL-BSSCT in the Slave section to open the configuration screen.



Step 8: Click ‘Slot Setup’ to setup the I/O modules on the XEL-BSSRT.

Step 9: Add your modules by selecting the Module Slot then selecting the module in the Module List and pressing the Left Arrow 
with label ‘Select’.



Step 10: Write your program to the XMC.



Section 3  – I/O Device Address Locations
• The direct variable addresses for the I/O configured can be found in the Master section of the EtherCAT Parameter section.
• The PDO Variable section will contain the device addresses and variable names to access the data.
• This screen can also be used to force I/O to certain values while in monitor mode.
• The variable names will start with _ECxxx where ‘xxx’ is the slave node number.

Step 1: Open the Master Section of the EtherCAT Parameters.



Step 2: Click ‘PDO Variable’ to see the I/O address list.

Digital Output variable 
and device addresses

Analog Output 
variable and device 
addresses

Outputs are assigned 
to the RxPDO 
parameters.



Digital Input variable 
and device addresses

Analog Input variable 
and device addresses

Inputs are assigned to the 
TxPDO parameters.



Section 4  – I/O Forcing from PDO Variable Screen
• The EtherCAT network must be connected with LS_Connect function block or use Online Menu -> EtherCAT Slave -> Connect.
• With the PDO Variable screen open, Start monitoring from the Monitor menu.

Double Click to set or 
force I/O point.

Double Click to set or 
force I/O point.



XMC06 – How to Review and Edit the EtherCAT Service Data Object (SDO)
• The EtherCAT Service Data Object (PDO) is used for asynchronous transmission of data between the master and slave nodes.
• The motion controller performs asynchronous service data communication for error information in the slave and parameter 

reading/writing.
• The EtherCAT Slave Information (ESI) file defines the parameters of the SDO for an EtherCAT slave device.
• XG5000 allows the SDO to be reviewed and modified for your system configuration.

Section 1 -  Reading the SDO of a EtherCAT slave
Step 1: Connect to the XMC with XG5000.

Step 2: Choose Online menu -> EtherCAT Slave -> Connect.  This will connect the EtherCAT network.



Step 3: Choose Online menu -> EtherCAT Slave -> Read SDO.  

Step 4: Choose the slaves to read SDO from. Press the OK button.



Section 2 -  Accessing the SDO of a EtherCAT slave
Step 1: In the XMC project,  Double click on the EtherCAT slave device to open its configuration window.



Step 2: Click ‘SDO Parameter’ in the EtherCAT slave configuration screen.



Step 3: Double Click on the Set Value Column of a parameter to modify. This example shows “Homing Method”.

Step 4: Enter the value for the parameter and Press OK when done.



Step 5: Connect to the XMC with XG5000.

Step 6: Choose Online menu -> EtherCAT Slave -> Connect.  This will connect the EtherCAT network.



Step 7: Choose Online menu -> EtherCAT Slave -> Write SDO.  



Step 8: Choose which EtherCAT slaves to write the SDO data too.  Press OK when done.



Step 9: Select Online Menu -> EtherCAT Slave -> Save SDO Parameter.  This will save the SDO parameters on the slave.



XMC07 – How to Review and Edit the EtherCAT Process Data Object (PDO) 
• The EtherCAT Process Data Object (PDO) is used to configure the synchronous communication between EtherCAT master and slaves.
• The TxPDO is the data transmitted from EtherCAT slave to EtherCAT master.
• The RxPDO is the data transmitted from the EtherCAT master to the EtherCAT slave.
• The EtherCAT Slave Information (ESI) file includes many options for TxPDO and RxPDO for an EtherCAT slave device.
• XG5000 allows the PDO to be reviewed and modified for your system configuration.

Section 1 -  Accessing the PDO of a EtherCAT slave
Step 1: In the XMC project,  Double click on the EtherCAT slave device to open its configuration window.



Step 2: Click ‘PDO Setting’ in the EtherCAT slave configuration screen.



Step 3: Select between TxPDO and RxPDO using the PDO Type Filter selection drop down.



Section 2 -  PDO Screen Layout

Select between TxPDO and RxPDO.

List of PDO data from ESI file

PDO data configured for Master and 
Slave to communicate to each other.

Select Which PDO assignment to 
modify and moving data from data 
list to Mapped Objects.

Choose Which PDO 
assignment the XMC 
uses for this slave.
Flag – Data in the PDO 
is fixed and can’t be 
changed.
SM- Sync manager 
determines which type 
of data is being 
transmitted.

Move items in the Mapped Object up 
and down in the ordering. Must 
select a Mapped Object for these to 
be active.

These must be check 
to have the master 
download the PDO 
to the slave device.



Section 3 -  Modifying the PDO
Step 1: Select the Mapped Object that you want to change.

Step 2: Press the Up Arrow to move the selected object to the PDOs To Map section.



Step 3: Select a new PDO object to add from the PDOs to Map list.

Step 4: Press the Down Arrow to move the selected object to the Mapped Objects section.
Note: Up to ten objects can be mapped in the Mapped Objects List.



XMC08 – Important Motion Flag Variables
• A Flag is a pre-defined memory location that indicates the real time operation, state, and vital information of the XMC. 
• These are designed to give the programmer quick access to important information and are extremely useful for ease of programming.
• Each flag is defined with a descriptive tag name that begins with  an underscore (“_”). 
• The tag name is aliased to a memory address located in the %F and %K area. 

Tag name Description

Flag Variable TagFlag Type Selection



Category Function
System Common functions of the CPU:  Run status, errors, clock, scan.

Data Log State and data for Data logging functionality.

Memory Card State and data for SD memory card.

Encoder Data for the built-in Encoder inputs.

Motion Common Common Status flags of the Motion controller.

Motion Axis Axis specific motion state and data.

Motion Axis Group Motion group state and data.

EtherCAT Master EtherCAT master motion state and data.

EtherCAT Slave EtherCAT slave motion state and data.

NC Channel NC Channel state and data.

NC Ch/Axis Displays the state of the axis configured for the NC Channel.



System Flags

System flags provide useful information for programming. Some helpful tags are highlighted below:

Provides high pulse for first half of time interval and low pulse for last half of time interval.

Provides ON/OFF or toggles by scan

Real Time Clock tags

1st scan action 



Motion Axis Flags
• Motion Axis Flags contain information about each axis.
• These can include axis ready status, power status, error status and more.
• These variables can be used in project code and added to the monitor window.

Select “Motion Axis” from the drop-down list.

Tip: Uncheck the “All” box and use the text entry to 
choose the axis number you want to look at.



EtherCAT Master Flags
• EtherCAT Master Flags contain information the XMC’s EtherCAT Connection.
• These variables can be used in project code and added to the monitor window.

Select “EtherCAT Master” from the drop-down list.



EtherCAT Slave Flags
• EtherCAT Slave Flags contain information about each slave.
• These can include status information and connection information.
• These variables can be used in project code and added to the monitor window.

Select “EtherCAT Slave” from the drop-down list.

Tip: Uncheck the “All” box and use the text entry to 
choose the slave number you want to look at.



Section 1 – Offline Diagnostics

XMC09 – EtherCAT Diagnostics of the XMC

• XG5000 can perform a few offline diagnostics for the EtherCAT network.
• Offline diagnostics include:

• EtherCAT Frame size examination
• ESI file assessment

 

• XG5000 can confirm frame sizes used by the configured EtherCAT slaves.
• A green status bar indicates that the configured PDO items and number of slaves is good for the EtherCAT frame size.
• A red status bar indicates that the configured PDO items or number of slaves are exceeding the maximum frame size.
• If the status bar is red, PDO items or slaves need to be deleted.

Section 1.1 – EtherCAT Frame Size Examination

Step 1: In the Project Window, Double click on ‘Master’ under the Motion Data -> EtherCAT Parameter section.



Step 2: Click on ‘PDO Variable’ to view the ‘Used Frame’ status.

Green Status shows frame size is good.
Red Status shows that too many slaves or PDO items have been added.

• The ESI (EtherCAT Slave Information) file is needed for setting up EtherCAT slaves for the XMC.
• XG5000 can perform a file assessment to make sure an ESI file is valid for the XMC.

Section 1.2 – ESI File Assessment

Step 1: In View menu, Select ‘ESI Library Window’.



Step 2: Right Click on the ESI file to analyze.  Select ‘Validate ESI File’.

Step 3: Press ‘OK’ on the pop up window to finish the assessment.

Step 4: Open the ‘Result’ Window to see the file assessment results.



Section 2 – EtherCat Slave Online Diagnostics
• The XMC has direct variable flags that provide slave status information.
• These direct variable flags are populated with data after connecting the EtherCAT network.
• XG5000 has a diagnostic screen available in the master window of the EtherCAT motion data.
Section 2.1 – EtherCAT Diagnostic Flags

Flag Name Flag Description

_SLVxx_ALStatus Shows the AL status of a slave.

_SLVxx_ALStatusCode Shows the error code of a slave.

_SLVxx_DLStatus Shows the link status information of a slave.

_SLVxx_LinkLostCounterA
_SLVxx_LinkLostCounterB
_SLVxx_LinkLostCounterC
_SLVxx_LinkLostCounterD

This count increases each time the port link is lost.

_SLVxx_InvalidFrameCounterA
_SLVxx_InvalidFrameCounterB
_SLVxx_InvalidFrameCounterC
_SLVxx_InvalidFrameCounterD

This count will increase if there are errors in frame formats such as Preamble, SFC and CRC.  

_SLVxx_RxErrorCounterA
_SLVxx_RxErrorCounterB
_SLVxx_RxErrorCounterC
_SLVxx_RxErrorCounterD

This count increases if there are physical layer errors occurring on a port.

_SLVxx_ForwardRXErrCounterA
_SLVxx_ForwardRXErrCounterB
_SLVxx_ForwardRXErrCounterC
_SLVxx_ForwardRXErrCounterD

Abnormal frames detected through the previous slaves received count.

Note: ‘xx’ represents the slave number.



Section 2.2 – EtherCAT Diagnostic Flags XG5000 Location
Step 1: Double click on ‘Global/Direct Variables’ to open the windows to access the diagnostic flags.

Step 2: Click on the ‘Flag’ tab.

Step 3: Select ‘EtherCAT Slave’ from the flag type.



Step 4: Uncheck the ‘All’ checkbox and enter a Slave Number to view.



If a problem occurs during EtherCAT communication, diagnosis with the diagnostic flags can be performed in the following sequences.
1. A slave with a non-zero value of the SLVxx_InvalidFrameCounter or SLVxx_RxErrorCounter shows the location where a problem 

has occurred.
2. Inspect the ethernet cables connected to the slave from step 1.

1. Confirm that the cable is not located close to a power cable or noise source.
2. Confirm that the cable is still functioning properly.
3. Confirm that the cable shields are properly grounded.

3. Inspect the power and grounding of the slave module.
4. Confirm if the problem is related with a specific device movement or if the device is defective.

Section 2.3 – EtherCAT Slave Diagnostic Steps



Section 3 – EtherCat Master Online Diagnostics
• XG5000 has a diagnostic screen available in the master window of the EtherCAT motion data.
• This screen can be used to determine if a slave drive supports the CiA402 Drive Profile.
• Slave error history can be seen from this screen.
• Slave status can also be changed.

Section 3.1 – EtherCAT Master Diagnostic Screen

Step 2: In the Project Window, Double click on ‘Master’ under the Motion Data -> EtherCAT Parameter section.
Step 1: Get online with the XMC.



Step 3: Select the ‘Diagnostics’ window.

Step 4: Start Monitoring by select Monitor Menu -> Start Monitoring.  This will populate data in the diagnostic screen.



Section 3.2 – EtherCAT Slave Revision Information
Note: The EtherCAT network must be connected through code or the Online Menu -> EtherCAT Slave -> Connect.

Right Click on a slave and Select ‘Slave Revision Information’.

Shows Slave name and firmware revision.

Shows supported CiA402 Drive Profile operation modes.

Shows current operation mode of the slave.



Section 3.3 – EtherCAT Slave Error History
Note: The EtherCAT network must be connected through code or the Online Menu -> EtherCAT Slave -> Connect.

Right Click on a slave and Select ‘Slave Error History’.

Shows which slave’s error history is being viewed.

Error History of the selected slave.



Section 3.4 – EtherCAT Slave Change Slave Status
Note: The EtherCAT network must be connected through code or the Online Menu -> EtherCAT Slave -> Connect.

Right Click on a slave and Select ‘Change Slave Status’.

Select the slave’s EtherCAT operation state status.

Shows the current EtherCAT operation state of the slave.



Section 3.5 – EtherCAT Slave Port Link Status
Note: The EtherCAT network must be connected through code or the Online Menu -> EtherCAT Slave -> Connect.

Right Click on a slave and Select ‘Slave Connection Status’.

Shows the status on the slave’s EtherCAT ports.



Section 4 – Status Monitor Screen
• The Status Monitor Screen will show information about the Axes.
• This screen is useful for troubleshooting and diagnosing issues.

Go to View Menu and Select ‘Status Monitor Window’.



Section 5 – Motion Command Window
• The Motion Command Window allows the user to send commands to an axis with XG5000.
• Make sure your system is safe and use caution when sending manual motion commands.

Go to View Menu and Select ‘Motion Command’.
Choose Axis to Command.

Command Buttons such as stop, 
error reset, and connect axes.

Motion commands and 
settings.



XMC10– Example Motion Code

LS_Connect must be called first to connect the EtherCAT network.

LS_Disconnect is used to disconnect the EtherCAT network.  Must be 
done before doing a project write if the network is connected.

Motion function blocks use an UINT 
variable for axis reference.  The value 
of ‘1’ will be axis 1.  So, ‘n’ will be 
axis n.
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